Recent Posts

Friday 29 September 2017

Configuring an IPv6 Network with RIPng

Configuring an IPv6 Network with RIPng

Hi ! everyone on today we are going to learn about how to configure an ipv6 network with RIPng with simplified explanation given below as screenshots with our topology.




Step 1: First we should assign ipv6 address to all PCs

PC0


 PC1

PC2

Step 2: We have to configure ipv6 with RIPng on Router R1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#ipv6 unicast-routing
R1(config)#interface g0/0
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:DA:1::1/64
R1(config-if)#ipv6 rip RIP1 enable
R1(config-if)#no shutdown




Now we can see the green color is the changed state to up on Router R1 connected to Switch1.

R1(config-if)#interface s0/0/0
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:DA:2::1/64
R1(config-if)#ipv6 rip RIP1 enable
R1(config-if)#ipv6 rip RIP1 default-information originate
R1(config-if)#clock rate 128000

R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#interface s0/0/1
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:DA:C::2/64
R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
R1(config-if)#exit
R1(config)#ipv6 route ::/0 s0/0/1

R1(config)#exit

R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...

[OK]

We can check our Router R1 by running-configure

R1#show running-config
Building configuration...

Current configuration : 1079 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524U2PY
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:DA:1::1/64
ipv6 rip RIP1 enable
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:DA:2::1/64
ipv6 rip RIP1 enable
ipv6 rip RIP1 default-information originate
clock rate 128000
!
interface Serial0/0/1
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:DA:C::2/64
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
ipv6 router rip RIP1
!
ip classless
!
ip flow-export version 9
!
ipv6 route ::/0 Serial0/0/1
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!

end


Step 3: After completing on router R1 we have to configure ipv6 on Router R2 with RIPng 

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#ipv6 unicast-routing
R2(config)#interface s0/0/0
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:DA:2::2/64

R2(config-if)#no shutdown




We can see the Router R2 connected with R1 turns to green color which means it changed state to up.

R2(config-if)#interface g0/0
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:DA:3::1/64

R2(config-if)#no shutdown




On the above screenshot we can see R2 connects Switch2 it shows in green color is that changed state to up.

R2(config-if)#interface s0/0/1
R2(config-if)#clock rate 128000
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:DA:4::1/64

R2(config-if)#no shutdown


R2(config-if)#ipv6 rip RIP1 enable
R2(config-if)#interface s0/0/0
R2(config-if)#ipv6 rip RIP1 enable
R2(config-if)#interface g0/0
R2(config-if)#ipv6 rip RIP1 enable

R2(config-if)#

R2#show run
Building configuration...

Current configuration : 976 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15242L3O
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:DA:3::1/64
ipv6 rip RIP1 enable
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:DA:2::2/64
ipv6 rip RIP1 enable
!
interface Serial0/0/1
no ip address
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:DA:4::1/64
ipv6 rip RIP1 enable
clock rate 128000
!
interface Vlan1
no ip address
shutdown
!
ipv6 router rip RIP1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end




R2#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
R ::/0 [120/2]
via FE80::1, Serial0/0/0
R 2001:DB8:DA:1::/64 [120/2]
via FE80::1, Serial0/0/0
C 2001:DB8:DA:2::/64 [0/0]
via Serial0/0/0, directly connected
L 2001:DB8:DA:2::2/128 [0/0]
via Serial0/0/0, receive
C 2001:DB8:DA:3::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:DA:3::1/128 [0/0]
via GigabitEthernet0/0, receive
L FF00::/8 [0/0]
via Null0, receive

R2#exit


On R1 router we can check by show ipv6 route command. 
R1>enable
R1#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB8:DA:1::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:DA:1::1/128 [0/0]
via GigabitEthernet0/0, receive
C 2001:DB8:DA:2::/64 [0/0]
via Serial0/0/0, directly connected
L 2001:DB8:DA:2::1/128 [0/0]
via Serial0/0/0, receive
R 2001:DB8:DA:3::/64 [120/2]
via FE80::2, Serial0/0/0
L FF00::/8 [0/0]
via Null0, receive

R1#

Step 4: Configure Router R3 on ipv6 with RIPng

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#ipv6 unicast-routing
R3(config)#interface s0/0/1
R3(config-if)#ipv6 address FE80::3 link-local
R3(config-if)#ipv6 address 2001:DB8:DA:4::2/64

R3(config-if)#no shutdown



Now in this step we can see green color which is change in state to up by connecting R2 router.

R3(config-if)#ipv6 rip RIP1 enable
R3(config-if)#interface g0/0
R3(config-if)#ipv6 address FE80::3 link-local
R3(config-if)#ipv6 address 2001:DB8:DA:5::1/64

R3(config-if)#no shutdown



We can see the change in state to up with show green color by connecting Switch3.

R3#copy run start
Destination filename [startup-config]?
Building configuration...

[OK]

On router R2 we have to do copy run start command as shown below.
R2>enable
R2#copy run start
Destination filename [startup-config]?
Building configuration...

[OK]

Step 5: Finally we have to configure on ipv6 ISP router with RIPng

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISP
ISP(config)#ipv6 unicast-routing

ISP(config)#interface s0/0/1
ISP(config-if)#clock rate 128000
ISP(config-if)#ipv6 address FE80::C link-local
ISP(config-if)#ipv6 address 2001:DB8:DA:C::1/64

ISP(config-if)#no shutdown



ISP(config-if)#exit
ISP(config)#ipv6 route 2001:DB8:DA::/61 s0/0/1

ISP(config)#exit

ISP#copy run start
Destination filename [startup-config]?
Building configuration...

[OK]

Now we can check by pinging on PC0 with ISP router as shown below




Therefore, all the routers and switches are connected each other with all PCs that the change in state to up. In this session we have learned how to configure ipv6 with RIPng with the help of packet tracer version 7.1.

No comments:

Post a Comment

Popular Posts